博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
1001. A+B Format (20)
阅读量:7071 次
发布时间:2019-06-28

本文共 1157 字,大约阅读时间需要 3 分钟。

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

#include <iostream>

#include <stack>
#include <stdlib.h>
using namespace std;
//题意很简单,就是货币格式表示法
int main()
{
int a,b;
cin>>a>>b;
stack<int> sta;
int c = a+b;
if(c<0)cout<<"-";//如果结果是复数,就先输出一个负号。
if(c==0) cout<<0;//如果结果是0,就直接输出
while(c!=0)
{
int temp = c%10;
c/=10;
sta.push(temp);
}//从个位开始依次入栈
int first=sta.size()%3;
int count=0;
while(!sta.empty())//出栈操作
{
cout<<abs(sta.top());
count++;sta.pop();
if(count==first&&sta.size()>0) {cout<<",";first = 10;count=0;}
if(count==3&&sta.size()!=0){cout<<",";count=0;}
}

}

转载于:https://www.cnblogs.com/LMIx/p/8602651.html

你可能感兴趣的文章
关于索引的基础知识
查看>>
全民WIFI上网计划
查看>>
Spring和SpringMVC父子容器关系初窥
查看>>
【原创】MySQL Proxy - read_query()
查看>>
Git使用总结(包含Git Bash和Git GUI的使用)
查看>>
forward与redirect的区别
查看>>
ViewPage控件
查看>>
实现SPF垃圾邮件防护功能
查看>>
Slave IO: Yes Slave SQL: No Seconds Behind Mast...
查看>>
eclipse 使用Maven deploy命令部署构建到Nexus上
查看>>
大型系统中使用JMS优化技巧–Sun OpenMQ
查看>>
滑动特效插件 - Swiper
查看>>
Oracle的TX锁(行级锁、事务锁)
查看>>
思达报表工具Style Report基础教程—用选择树进行图表的钻取
查看>>
JQuery empty selector
查看>>
Direct vs non-direct ByteBuffer
查看>>
SQLSERVER——Log Explorer 数据恢复
查看>>
oracle job最简单创建代码
查看>>
常识 跳转读取js函数
查看>>
Linux内核中的jiffies及其作用介绍及jiffies等相关函数详解
查看>>